Excel e gli applicativi Microsoft Office Riferimento matrice formula sempre in testo o in valore

LoginRegistrati
Stai vedendo 6 articoli - dal 1 a 6 (di 6 totali)
  • Autore
    Articoli
  • #17282 Risposta

    Max10
    Partecipante

      Salve a tutti,

      forse faccio una domanda banale ma è possibile fare in modo che in un certa verticale o un indice confronta il riferimento della matrice sia sempre formattato dalla formula in testo o in valore?

      Mi spiego meglio:

      se devo fare un cerca verticale di un codice numerico formattato a volte come testo e a volte come numero in un database dove allo stesso modo è formattato a volte come testo ed altre come numero, posso fare in modo di imporre alla ricerca il formato sia di ciò che cerco sia di dove cerco?

      Vorrei rendere la cosa automatica senza ogni volta sistemare le 2 colonne in formato testo o valore.

      Grazie

      #17285 Risposta

      vecchio frac
      Senior Moderator
      • Sfida #1
        171 pts

        Stai parlando di una soluzione solo lato formule?

        Puoi allegare un esempietto della situazione (che mostri anche eventuale errore di CERCA.VERTICALE) e del risultato voluto?

        #17304 Risposta
        cromagno
        cromagno
        Partecipante
          5 pts

          Ciao a tutti,
          @max10

          conviene "trasformare" tutto in testo visto che un numero può essere rappresentato in formato testo ma non il contrario.
          Supponendo che i dati si trovino nel range A1:B10 e che il valore da cercare sia in cella C1, una formula che potresti utilizzare è:

          =CERCA.VERT(C1&"";INDICE($A$1:$B$10&"";;);2;FALSO)

          #17305 Risposta
          Marius44
          Marius44
          Moderatore
          • Sfida #4
            11 pts

            Salve a tutti

            Come sempre, ottima la soluzione di @cromagno (ciao Tore)

            Se, invece, si volesse sapere in quale riga si trova il valore cercato io userei la seguente formula (matriciale - da confermare con Ctrl*Shift+Enter) che esegue la ricerca SOLO SU UNA COLONNA

             

            =CONFRONTA(C1&"";(A1:A10&"");0)

             

            Ovvio che si ferma (come anche la formula di cui al post precedente) alla prima occorrenza trovata.

            Ciao,

            Mario

             

            PS - come sapete con le formule non è che ci vado a nozze. Mi date conferma della correttezza della formula da me indicata? Grazie.

            #17310 Risposta

            Max10
            Partecipante

              Grazie mille!

              ho risolto.

              prima usavo =CERCA.VERT(testo(C1;0);$A$1:$B$10;2;FALSO)

              ma usando C1&"" e la funzione indice per la matrice con &"" è tutto più immediato.

              Cambia qualcosa concatenare "" a C1 prima o dopo?

              #17317 Risposta
              cromagno
              cromagno
              Partecipante
                5 pts

                Cambia qualcosa concatenare "" a C1 prima o dopo?

                Non cambia nulla... è solo "prassi" metterlo alla fine per una miglior lettura della formula.

                @mario

                Mi date conferma della correttezza della formula da me indicata?

                Si Mario, è corretta (puoi anche togliere le parentesi tonde al secondo argomento)...
                In quella che ho proposto ho aggiunto la funzione INDICE per evitare di doverla confermare come "MATRICIALE" e naturalmente si può fare la stessa cosa anche con la formula da te proposta.

                Ciao
                Tore

              LoginRegistrati
              Stai vedendo 6 articoli - dal 1 a 6 (di 6 totali)
              Rispondi a: Riferimento matrice formula sempre in testo o in valore
              Gli allegati sono permessi solo ad utenti REGISTRATI
              Le tue informazioni:



              vecchio frac - 2714 risposte

              albatros54
              albatros54 - 714 risposte

              patel
              patel - 626 risposte

              Marius44
              Marius44 - 542 risposte

              Luca73
              Luca73 - 508 risposte