Excel e gli applicativi Microsoft Office Conta celle contenenti formule

LoginRegistrati
Stai vedendo 6 articoli - dal 1 a 6 (di 6 totali)
  • Autore
    Articoli
  • #21538 Risposta

    ABRAMO48
    Partecipante
      1 pt

      Buongiorno,

      Come posso fare per contare il numero di celle che, in un intervallo, contengono formule?

      grazie!

      #21541 Risposta
      D@nilo
      D@nilo
      Partecipante
        2 pts

        Buongiorno

        ipotizziamo l'intervallo A1:D5 in una cella metti

         

        =MATR.SOMMA.PRODOTTO(--VAL.FORMULA(A1:D5))

        #21545 Risposta
        albatros54
        albatros54
        Moderatore
        • Sfida #2
          42 pts

          lato VBA

          Option Explicit
          Sub SpecialCells()
              Dim ws As Worksheet
              Dim rgSpecial As Range
              Dim a As Integer
              On Error Resume Next
              Set ws = ThisWorkbook.Worksheets("foglio1")
              Set rgSpecial = ws.Range("a1:d5").Cells.SpecialCells(xlCellTypeFormulas, xlFormula)
              a = WorksheetFunction.Count(rgSpecial)
              Set rgSpecial = Nothing
              Set ws = Nothing
          End Sub
          

           

          Qual è il punto di avere gusti diversi, se non mostrare che i cervelli lavorano diversamente, che pensiamo diversamente? ( Alan Turing)
          Sempre il mare, uomo libero, amerai!
          ( Charles Baudelaire )
          #21553 Risposta

          ABRAMO48
          Partecipante
            1 pt

            ottimo! ma 

            Set rgSpecial = ws.Range("a1:d5").Cells.SpecialCells(xlCellTypeFormulas, xlFormula)

            mi da errore: "non è stara trovata alcuna cella" quando non ne trova, come faccio ad intercettare questo caso?

            #21554 Risposta

            ABRAMO48
            Partecipante
              1 pt

              ovvio, con ON ERROR ...

              #21558 Risposta

              ABRAMO48
              Partecipante
                1 pt

                già, ... era anche nell'esempio ...

              LoginRegistrati
              Stai vedendo 6 articoli - dal 1 a 6 (di 6 totali)
              Rispondi a: Conta celle contenenti formule
              Gli allegati sono permessi solo ad utenti REGISTRATI
              Le tue informazioni:



              vecchio frac - 2748 risposte

              albatros54
              albatros54 - 735 risposte

              patel
              patel - 636 risposte

              Marius44
              Marius44 - 557 risposte

              Luca73
              Luca73 - 523 risposte