Excel e gli applicativi Microsoft Office Formula di richiamo codice

LoginRegistrati
Stai vedendo 8 articoli - dal 1 a 8 (di 8 totali)
  • Autore
    Articoli
  • #27176 Risposta

    nicopana
    Partecipante

      Nel file allegato avrei necessità, nel foglio riep dalla cella B2 alla cella B4, di richiamare uno o più codici presenti nella colonna A del foglio "dati per stampa contabilità" che hanno un valore di costo diverso da zero nel mese da me selezionato invece nel foglio riep cella B1. 

      E' come se, scegliendo ad esempio come mese Giugno, dovrebbero comparirmi in ordine il codice 26-10 e 28-12 perché entrambi a giugno con un valore di costo diverso da 0, e dovrebbero comparire nelle celle B2 e B3 del foglio riep.

      Allegati:
      You must be logged in to view attached files.
      #27182 Risposta
      PMC77
      PMC77
      Partecipante
        8 pts

        Ciao @nicopana

        Puoi fare una formula SE annidata una dentro l'altra

        Anche se secondo me converrebbe una piccola macro che scorre le colonne del foglio riepilogo cercando il mese che ti interessa e sposta poi i valori

        Ciao

        Paolo

        #27192 Risposta
        D@nilo
        D@nilo
        Partecipante
          5 pts

          Buonasera

          in B2 del foglio riep da trascinare in basso

           

          =SE.ERRORE(INDICE('dati per stampa contabilità'!$A$2:$A$1000;AGGREGA(15;6;RIF.RIGA($A$2:$A$1000)-1/(INDIRETTO("'dati per stampa contabilità'!"&INDIRIZZO(2;CONFRONTA($B$1;'dati per stampa contabilità'!$B$1:$M$1;0)+1)&":"&INDIRIZZO(1000;CONFRONTA($B$1;'dati per stampa contabilità'!$B$1:$M$1;0)+1))>0);RIF.RIGA($A1)));"")

          #27332 Risposta

          nicopana
          Partecipante

            Grazie per la risposta, e scusate il ritardo, ma sono stato fuori (per fortuna per ferie, anche se sono durate molto poco).

            Ho testato la formula, e forse come al solito sono incappato nel solito errore di avervi proposto un test che in realtà non rispecchia totalmente il file originale di destinazione.

            Cosa cambierebbe nella formula se le tre celle in giallo (A2:A4) corrispondessero alle celle AM45:AM47?

            #27333 Risposta
            D@nilo
            D@nilo
            Partecipante
              5 pts

              Ciao

              Le celle gialle sono da b2 a b4 del foglio Riep ed è  dove hai chiesto  i risultati....se la formula la metti in b2 o un'altra parte non cambia nulla....

              Quindi se la formula non è risolutiva allega il file con lì a stessa struttura dell originale dove metti un po' di dati e il risultato da ottenere scritto a mano 

              #27338 Risposta

              nicopana
              Partecipante

                Allego il file di destinazione originale che mi serve.

                C'è sempre lo stesso foglio "dati per stampa contabilità", e nella cella AM45 del foglio StampaContabilità, avendo qui selezionato in F3 il mese Giugno, dovrebbe uscire il codice 26-10

                Allegati:
                You must be logged in to view attached files.
                #27355 Risposta
                D@nilo
                D@nilo
                Partecipante
                  5 pts

                  Ciao

                  in AM45 da trascinare in basso

                   

                  =SE.ERRORE(INDICE('dati per stampa contabilità'!$A$2:$A$1000;AGGREGA(15;6;RIF.RIGA($A$2:$A$1000)-1/(INDIRETTO("'dati per stampa contabilità'!"&INDIRIZZO(2;CONFRONTA(MESE($F$3&0);INDICE(MESE('dati per stampa contabilità'!$B$1:$M$1);;);0)+1)&":"&INDIRIZZO(1000;CONFRONTA(MESE($F$3&0);INDICE(MESE('dati per stampa contabilità'!$B$1:$M$1);;);0)+1))>0);RIF.RIGA($A1)));"")

                  #27356 Risposta

                  nicopana
                  Partecipante

                    Grazie, funziona

                  LoginRegistrati
                  Stai vedendo 8 articoli - dal 1 a 8 (di 8 totali)
                  Rispondi a: Formula di richiamo codice
                  Gli allegati sono permessi solo ad utenti REGISTRATI
                  Le tue informazioni:



                  vecchio frac - 2750 risposte

                  albatros54
                  albatros54 - 1009 risposte

                  patel
                  patel - 957 risposte

                  Marius44
                  Marius44 - 825 risposte

                  Luca73
                  Luca73 - 700 risposte