Ultima cella piena

  • Ultima cella piena di un range di Neofita
    Ho questa situazione: da a1 ad a100 ho tutte date (ordinate in modo crescente), nella colonna b ho tanti numeri, le celle del range da b1 a b100 sono piene fino ad una certa cella (non vi sono celle vuote fra le celle piene).
    mi serve sapere qual'e' l'ultima cella della colonna b che contiene valori oppure conoscere l'ultima data, della colonna a, la cui corrispondente cella di b contiene valori.
    qualcuno mi può aiutare a trovare la soluzione: importante mi servono formule e non macro perchè, dopo aver trovato la cella che mi interessa, devo fare altre elaborazioni con quei dati.
    grazie a tutti.
    neofita

    di Enzo
    Con le formule puoi intervenire solo su singola cella
    possa darti due istruzioni macro


     
    RANGE ("A1").SELECT
    Selection.End(xlDown).Select
    ''SI POSIZIONA SULL'ULTIMA CELLA PIENA CHE INCONTRA
    'OPPURE
    RANGE ("A1").SELECT
    DO
    ACTIVECELL.OFFSET (1).SELECT
    LOOP UNTIL ACTIVECELL.VALUE= ""
    ACTIVECELL.OFFSET (-1).SELECT
    
    

    Ultima cella piena di un range di Neofita
    Grazie enzo per la tua risposta (mi è utile per un'altra situazione di posizionamento cella) però a me serve sapere proprio qual'e' la cella che corrisponde alle condizioni esposte: la devo utilizzare per dei calcoli. puoi trovarmi la soluzione?
    grazie
    ciao, neofita

    Ciao neofita di Apoben64
    Prova questa funzione , dovrebbe darti l'ultimo valore inserito.

    ciao luca
     
    =INDICE(B1:B100;CONTA.NUMERI(B1:B100)) 
    

    Ultima cella piena di un range di Neofita
    Grazie luca hai risolto la mia esigenza.

    posso sfruttare la tua cortesia per chiederti una soluzione a quest'altra mia esigenza?

    e' tutto come il caso precedente ma adesso le celle da b1 a b100 sono tutte piene (le ultime celle contengono zero se la data, nella corrispondente cella della colonna a, è maggiore della data odierna):
    mi serve sapere qual'e' l'ultima cella, della colonna b, che contiene valori maggiori di zero.
    grazie anticipato.
    neofita

    di Enzo
    Prova cosi'

     
    Range("B1").Select
    Do
    ActiveCell.Offset(1).Select
    Loop Until ActiveCell.Value = ""
    Do
    ActiveCell.Offset(-1).Select
    Loop Until ActiveCell.Value > 0
    

    Ultima cella piena di un range di Neofita
    Grazie enzo, hai risolto il mio secondo caso.
    alla prossima.
    ricky53