Excel e gli applicativi Microsoft Office Spezzare colonna exel in più colonne di determinata lunghezza

LoginRegistrati
Stai vedendo 6 articoli - dal 1 a 6 (di 6 totali)
  • Autore
    Articoli
  • #28913 Risposta

    Giacomo

      Buongiorno! Ho 3 colonne exel  ognuna contenete 26244 celle, come posso fare per spezzarle in blocchi sempre da 3 ma di 162 celle ciascuna? 

      Grazie 🙂

      #28918 Risposta
      PMC77
      PMC77
      Partecipante
        9 pts

        Ciao @giacomo!

        Credo che con funzioni di Excel sia impossibile!

        Come sei messo a VBA per scrivere una Macro che faccia quanto da te desiderato?

        Ciao

        Paolo

        #28931 Risposta
        D@nilo
        D@nilo
        Partecipante
          8 pts

          Buonasera a tutti

          si può fare anche con le formule in mancanza di un file di esempio ipotizzo i dati iniziali in A1:C26244

          in G1 da trascinare a destra per 485 colonne (in questo caso fino a RX1...le colonne devono essere 486) e poi in basso fino a riga 162

           

          =INDICE($A$1:$C$26244;SOMMA(RESTO(RIF.RIGA($A1)-1;162)+1;162*QUOZIENTE(RIF.COLONNA(A$1)-1;3));RESTO(RIF.COLONNA(A$1)-1;3)+1)

          #29131 Risposta
          thunder
          thunder
          Partecipante

            ciao a tutti. Non credo di avere capito bene perdonami. Come devono essere spezzate le colonne? Riesci ad inserire un file di esempio?

            #29132 Risposta
            D@nilo
            D@nilo
            Partecipante
              8 pts

              Ciao

              Guarda che Giacomo ha alzato le vele...la formula proposta fa quello che chiede

              #29143 Risposta
              thunder
              thunder
              Partecipante

                Ciao Danilo, scusa avevo visto che non aveva messo il risolto e nemmeno un ringraziamento per l'aiuto! Alla prossima

              LoginRegistrati
              Stai vedendo 6 articoli - dal 1 a 6 (di 6 totali)
              Rispondi a: Spezzare colonna exel in più colonne di determinata lunghezza
              Gli allegati sono permessi solo ad utenti REGISTRATI
              Le tue informazioni:



              vecchio frac - 2750 risposte

              albatros54
              albatros54 - 1036 risposte

              patel
              patel - 1029 risposte

              Marius44
              Marius44 - 918 risposte

              Luca73
              Luca73 - 749 risposte