Sviluppare funzionalita su Microsoft Office con VBA Raggruppamento e conteggio dati

LoginRegistrati
Stai vedendo 9 articoli - dal 1 a 9 (di 9 totali)
  • Autore
    Articoli
  • #31044 Risposta

    Buonasera, chiedo un aiuto per risolvere questo piccolo problema:

    in un foglio Excel da A3 ad An registro dei valori numerici (positivi o negativi)

    a partire dalla cella E3 vorrei riportare in successione e senza ripetizione i valori registrati e da F3 il numero di volte della presenza del valore stesso.

    Allego file Excel.

    Ringrazio anticipatamente

    Allegati:
    You must be logged in to view attached files.
    #31046 Risposta
    Marius44
    Marius44
    Moderatore
      36 pts

      Ciao

      Prova con queste formule

      in F3 =CONTA.SE($A$3:$A$15;"<="&E3)

      in F4 =CONTA.PIÙ.SE($A$3:$A$15;"<="&E4;$A$3:$A$15;">"&E3) da copiare in basso

       

      Ciao,

      Mario

       

      PS - Non comprendo perchè hai inserito la tua richiesta nella sezione VBA

       

      #31047 Risposta

      Grazie, sto cercando di eseguire il conteggio in un modulo scritto in VBA e voglio sapere se esiste la possibilità di trasformare le formule in linguaggio di programmazione

      #31048 Risposta
      Marius44
      Marius44
      Moderatore
        36 pts

        Ciao

        Che io sappia, qualsiasi formula si può trasformare in linguaggio VBA magari con un approccio diverso.

        Ma non dici se le formule suggerite sortiscono l'esito sperato!

         

        Ciao,

        Mario

        #31049 Risposta

        Ho verificato, non ottengo il risultato sperato. Cerco di analizzare meglio il problema e faccio sapere. Michele

        #31050 Risposta
        patel
        patel
        Moderatore
          43 pts

          Per iniziare potresti:

          attivare il registratore di macro

          selezionare il range da trattare e copiarlo in colonna E

          Dati, rimuovi duplicati, ordina

          chiudere il registratore

          fatto questo per ogni dato ormai univoco in colonna E conti con un ciclo le occorrenze in colonna A

           

          #31051 Risposta

          allego file dove trovo la soluzione con formule. vorrei sapere se gli stessi risultati si potrebbero ottenere con il VBA.

          Allegati:
          You must be logged in to view attached files.
          #31053 Risposta
          patel
          patel
          Moderatore
            43 pts

            Certamente si possono ottenere, ma hai provato a fare quello che ti ho consigliato ? La politica del forum è insegnare a fare e non fornire soluzioni chiavi in mano.

            #31054 Risposta

            perfetto, ho capito come iniziare, l'uso del registratore di macro mi ha dato l'imput

          LoginRegistrati
          Stai vedendo 9 articoli - dal 1 a 9 (di 9 totali)
          Rispondi a: Raggruppamento e conteggio dati
          Gli allegati sono permessi solo ad utenti REGISTRATI
          Le tue informazioni:



          vecchio frac - 2750 risposte

          patel
          patel - 1089 risposte

          albatros54
          albatros54 - 1062 risposte

          Marius44
          Marius44 - 1000 risposte

          Luca73
          Luca73 - 798 risposte