Excel e gli applicativi Microsoft Office Elenco a discesa concatenato da tabella

LoginRegistrati
Stai vedendo 2 articoli - dal 1 a 2 (di 2 totali)
  • Autore
    Articoli
  • #16958 Risposta

    acarraro89
    Partecipante
    • anraro19

      Ciao!

      scopo: creazione di un file excel che, inserito un codice, mi dia come risultato SI o NO in base ai dati di una tabella

      applicazione: l'applicazione è per una gamma di pompe di calore da consegnare ai clienti per poter verificare la detraibilità o meno

      problema: la creazione degli elenchi di discesa

      ho creato un file di esempio molto più semplice di quello che sto facendo:
      - nel foglio "nascosto" ho tutti i dati che mi servono;
      - il foglio "analisi" sarà l'interfaccia;
      - nelle celle gialle ci sono gli elenchi;
      - concatenando le celle gialle si crea il codice, con un cerca.vert mi cerco la risposta al test "SI" "NO" sulla tabella in foglio "nascosto";

      In questa maniera però posso creare codici inesistenti e il cerca.vert di conseguenza darmi errore.

      Utilizzare la funzione "indiretto" in convalida dati potrebbe essere l'alternativa. La ritengo irrealizzabile in quanto nel mio caso reale avrei troppe combinazioni di codici e dovrei creare troppe funzioni.

      Ci sono soluzioni migliori o funzioni per poter realizzare quanto da me chiesto?

      Grazie

      Allegati:
      You must be logged in to view attached files.
      #16962 Risposta

      vecchio frac
      Senior Moderator
      • Sfida #1
        145 pts

        Credo che senza poter usare VBA la soluzione più semplice sia non di combattere l'errore ma di mostrarlo in forma più umana. Chiaramente gli elenchi non possono essere basati su una convalida così articolata nè probabilmente è costruttivo pensare a un elenco dinamico (bisognerebbe anche rimuovere i duplicati).
        Correggerei quindi la formula che gestisce il test finale con SE.ERRORE:

        D10:  =SE.ERRORE(CERCA.VERT(CONCATENA(B8;C8;D8;E8);Tabella1;6;FALSO);"Not found")
      LoginRegistrati
      Stai vedendo 2 articoli - dal 1 a 2 (di 2 totali)
      Rispondi a: Elenco a discesa concatenato da tabella
      Gli allegati sono permessi solo ad utenti REGISTRATI
      Le tue informazioni:



      vecchio frac - 2136 risposte

      albatros54
      albatros54 - 650 risposte

      patel
      patel - 510 risposte

      Marius44
      Marius44 - 409 risposte

      Luca73
      Luca73 - 373 risposte