cercavert



  • cerca.vert ? di stefanmi (utente non iscritto) data: 04/06/2013 00:13:10

    vorrei un aiuto da voi esperti di excel, ho un database con una lista di indirizzi e voglio abbinare una zona a un certo numero di vie, ho provato con una formula cerca.vert ma funziona a metà dove sbaglio secondo voi


  • cerca.vert di Santuberto (utente non iscritto) data: 04/06/2013 08:21:46

    Buongiorno. Ho fatto una prova con il tuo esempio. Perché funzioni, è necessario che nella colonna “O” ci siano i nomi uguali a quelli che si vanno a cercare (Via Galileo Galiei e non Via Galileo Gali; Via Dante Alighieri e non Via Papa Paolo etc). Cordiali saluti.


  • CERCA.VERT di Santuberto (utente non iscritto) data: 04/06/2013 09:10:37

    Buondì. Un'altra cosa: nel CERCA.VERT per definire l'intervallo, prova a sostituire 1 con FALSO. Cordiali saluti.


  • di stefanmi (utente non iscritto) data: 04/06/2013 09:21:36

    quello che dici tu è vero, ma il mio problema è che ho una lista di vie senza numero civico e nel database invece ho l'indirizzo con numeri civici diversi per la stessa via e puo anche succedere che la via non sia scritta proprio nella maniera giusta per quello avevo messo 1 invece di 0 grazie


  • di Vecchio Frac data: 04/06/2013 09:45:52

    Mi chiederei piuttosto quale risultato vuoi ottenere se hai vie uguali ma in città diverse.


  • di Mister_x (utente non iscritto) data: 04/06/2013 10:00:02

    ciao

    in questo caso per la ricerca devi utilizzare caratteri jolly, in H2 la formula

    H2=CERCA.VERT("*"&STRINGA.ESTRAI(A2;1;10)&"*";$O$2:$P$21;2;0)

    PS pero' stai attento perche' nel tuo database di O2:O21 hai dei nomi doppi con riferimenti numerici diversi vedi quelli colorati che io il secondo ho messo a valore 0, vedi il tuo file modificato allegato

    ciao da Mister_x
     
    H2=CERCA.VERT("*"&STRINGA.ESTRAI(A2;1;10)&"*";$O$2:$P$21;2;0)


  • di Vecchio Frac data: 04/06/2013 10:09:42

    Appunto.
    La zona cambia, non solo da città a città (vie omonime), ma anche nella stessa città (se la via è molto lunga può esserci benissimo una suddivisione in zone, addirittura può cambiare dal lato destro al lato sinistro della stessa strada); quindi va definito meglio il criterio di assegnazione.


  • di stefanmi (utente non iscritto) data: 04/06/2013 13:07:28

    hai ragione Vecchio frac ho sbagliato ma la lista la devo fare di un solo paese


  • di stefanmi (utente non iscritto) data: 04/06/2013 13:12:35

    per Mister x avevo fatto un rimuovi duplicati quindi mi sono rimasti dei dati simili

    grazie mille è quello che volevo, se non chiedo troppo me la puoi spiegare questa formula


  • di Mister_x (utente non iscritto) data: 04/06/2013 18:44:29

    ciao

    l'utilizzo dei caratteri jolly serve per far si che se in una ricerca, vediamo il tuo casa , devo trovare una parola ma non so' a priori coma si chiama o come e' definita si adotta questo sistema, in parole povere
    quando si usava il DOS o anche quando tu fai un cerca in windows se tu non sai il nome del file da cercare o la sua estensione metti gli *
    ess. ammettiamo che tu devi trovare un file di nome Tizio.xxx o Tizia.xjz pero in questo caso non ti ricordi se e' Tizio o Vizio o Tizia e ti sei dimenticato anche l'estensione. in cerca metterai
    *izi*.* e cosi troverai tutti i file da scegliere
    nel tuo caso
    H2=CERCA.VERT("*"&STRINGA.ESTRAI(A2;1;10)&"*";$O$2:$P$21;2;0)
    alla voce valore ho inserito l'opzione dei caratterri , ho estartto solo un pezzo di stringa dato che quando vado a fare la ricerca nella mia colonna se trovo il valore di Stringa:estrai() i caratteri jolly sostituiscono tutto quello che vi e' prima e dopo il mio pezzo di valore cercato
    se proprio vuoi fare una prova sostituisci la funzione che ho passato con questaltri valori dove andiamo a eliminare la parola VIA e sfriuttiamo i caratteri jolly e vedrai il risultato uguale perche' il primo * sostituisce le prime tre lettere di ogni cella
    H2=CERCA.VERT("*"&STRINGA.ESTRAI(A2;4;6)&"*";$O$2:$P$21;2;0)

    spero di essermi fatto capire
    ciao da Mister_x


  • di stefanmi (utente non iscritto) data: 04/06/2013 19:36:11

    grazie mille, molto gentile


  • di stefanmi (utente non iscritto) data: 04/06/2013 21:26:51

    vorrei ancora un consiglio su come fare questa cosa,
    dovrei suddividere le varie vie di un paese in zone differenti per poter vedere da che zona arrivano maggiormente i miei clienti, per non farlo manualmente inserendo via per via guardando una piantina, grazie


  • di stefanmi (utente non iscritto) data: 10/06/2013 10:22:50

    scusa Mister_x la formula va bene solamente che se ci sono delle vie con meno di 10 caratteri mi da errore es: VIA PO 25 come si puo' risolvere